Introduction to WinMDI 2.8 (J. Trotter 1993-1998)
for the Analysis of
Flow Cytometry Listmode Data Files

Objectives of this tutorial:

- Open a listmode data file
- Create histograms (single, dual, and 3D histograms)
- Perform gating
- Perform original analysis
- Display statistics

Gérald GREGORI, Ph.D.
Kathy RAGHEB, M.T.(A.S.C.P.)
J. Paul ROBINSON, Ph.D.
Purdue University Cytometry Laboratories
Hansen Life Sciences Research Building, B050
201 S. University Street, West Lafayette, IN 47907-2064, USA
e-mail: gregori@flowcyt.cyto.purdue.edu
http://www.cyto.purdue.edu
Contents

I. How to Install WinMDI 2.8 ........................................................................................................ 1
II. How to Start WinMDI 2.8 ...................................................................................................... 1
III. How to Create a Single-parameter Histogram ................................................................ 3
IV. How to Create Histogram Overlay .................................................................................. 5
V. How to Create a Dual-parameter Histogram ..................................................................... 6
  1. How to create a dotplot .................................................................................................... 6
  2. How to create a Density plot or a Contour Plot ........................................................... 8
  3. How to create a 3-dimensional display ....................................................................... 10
  4. How to change the parameter labels and font ............................................................. 11
  5. How to display a title or write annotations on a graph .............................................. 11
VI. Zoom .................................................................................................................................. 12
VII. How to Create and Display Several Graphs on the Screen ........................................... 13
VIII. Regions and Gates ......................................................................................................... 14
  1. Create a region on a 1-parameter histogram .............................................................. 15
  2. Create a region on a 2-parameter histogram .............................................................. 16
  3. How to create a quadrant ............................................................................................ 17
  4. How to delete, move, or adjust a region ...................................................................... 18
  5. Create gates ................................................................................................................ 19
IX. Convert a FCS file to a text file ....................................................................................... 20
  1. Convert a data file ....................................................................................................... 20
  2. Only convert the data from a gated region ................................................................ 20
X. Display Statistics ................................................................................................................ 21
XI. Work with a Batch File ..................................................................................................... 22
XII. Overview ......................................................................................................................... 23
   What we like ..................................................................................................................... 23
   What we dislike ............................................................................................................... 24
Quick Start in 10 steps ......................................................................................................... 25
  1. To start WinMDI 2.8 .................................................................................................... 25
  2. To display a 2-parameter histogram ......................................................................... 25
  3. To create a 3D plot ..................................................................................................... 25
  4. To rotate a 3D graph .................................................................................................. 26
  5. To display a new single-parameter histogram ......................................................... 26
  6. To create a region ....................................................................................................... 26
  7. To create gates ............................................................................................................ 27
  8. To display statistics .................................................................................................... 27
  9. To create histogram overlay ....................................................................................... 28
 10. To create 3D view of histograms .............................................................................. 28
I. How to Install WinMDI 2.8

The Windows Multiple Document Interface software (WinMDI) is freeware designed by J. Trotter (1993-1998; trotter@scripps.edu) to analyze flow cytometric listmode data files. You can download it from the URL http://facs.scripps.edu/software.html or find it on any of the Purdue CD-Roms. To install WinMDI 2.8 on your computer, just click on the web page link corresponding to your office system (Windows 95/98/NT or Windows3.1/NT 3.x) and open (or save on your computer and install later) the corresponding wm28w95.exe or winmdi28.exe programs. Follow then the instructions.

The minimum system requirements are:

- Processor: 486/33 + 387 fpu math chip or better with 8 megabytes memory.
- Recommended: 486/66 with 16MB RAM or better
- Monitor: SVGA 800x600 or 1024x768 recommended.
- OS: MS DOS 5.0 or later + MS Windows 3.1 or later, Windows NT, Windows XP, or OS/2
- Windows 3.1: Use Microsoft's SMARTDrive or other disk cache program.

Hint!

I SUGGEST THAT YOU USE LISTMODE DATA FILES WITH 8.3 FORMAT FILE NAMES.

II. How to Start WinMDI 2.8

To start WinMDI just click on the WinMDI icon on the desktop, or use Start → Programs → WinMDI → WinMDI.exe. The following screen is displayed.
With WinMDI 2.8 it is possible to create single-parameter histograms, dual-parameters histograms (also called cytograms), and even 3D histograms. The *WinMDI Display* dialog window offers 4 different graph styles (see figures below):

- **Histogram**: displays one or more parameters as a frequency distribution (256 or 1024 channels).
- **Dotplot**: displays correlated data from any two parameters at a 256x256 resolution. Each dot corresponds to an event analyzed by the flow cytometer. Of course, several events can occupy the same dot if they have the same parameter intensities.
- **Density plot**: displays two parameters as a frequency distribution. Color is used to code the different frequencies of events.
- **Contour plot**: like a dotplot, a contour plot displays correlated data from any two parameters, with contour lines joining points of equal elevation (frequency distribution).
III. How to Create a Single-parameter Histogram

From the WinMDI Display dialog window select the “Histogram” style and click the OK button. A new window allows you to navigate to the sample folder where the listmode data file to analyze is recorded.

When the file is selected, press OK. The Select Parameters dialog window appears for selection of the parameter to display.

Using the scrolling bar, select the parameter you want to display (FS: forward-angle light scatter; SS: right-angle light scatter; Fl1, Fl2, ..., Fln: the first, second, and nth fluorescence recorded by the cytometer). Click the “Read” button to display the corresponding histogram.

All the parameters are automatically recorded within each listmode data file. You do not need to type them in the software.
**Hint!**

Sometimes WinMDI does not automatically recognize which amplification is used (linear or logarithmic). You need to specify the scale by selecting **Tools → Set LinLog** to open the **Lin/Log Variables** dialog window. Then check the corresponding scale for each parameter.

Very often it is necessary to change the position of the histogram and optimize the size by stretching its different borders and/or corners.

In the **Select Parameters** dialog window scroll bar, the “Show All Parameters” option generates a single graph in which all the histograms of all the different parameters are plotted together. If you click on the graph and select “Format” in the popup menu the **Format Histogram** dialog window is displayed (see below).

![Format Histogram Dialog Window](image)

Among the available options you can, for instance:

- Set the color of each histogram. Just select the corresponding histogram name and select the color (scroll menu). You can fill the histograms with their respective color (check the “Solid Fill” check box) or leave them empty (uncheck the box).
- Rescale the histograms by changing the “Y Scale” value.
- Change the thickness of the lines (change the “Line Width” option);
- Display all the histograms in black & white (check the “B+W” check box).
- Display all the histogram in 3 dimensions (check the “3D View” check box).
- Smooth the histograms.
- Set up a logarithmic scale for the vertical axis.
- Insert a title (see the “Title” scroll menu).
IV. How to Create Histogram Overlay

You can create a histogram overlay using WinMDI 2.8 (see figure below).

![Histogram Overlay Example](image)

To create the overlay:

1. Create a single-parameter histogram from a listmode data file: open the data file by clicking **File ➔ Open File**, then navigate to the file and press OK. Click on the “Histogram” style, and select a parameter. Click on the “Read” button to display the graph.

2. In the same way, open a new data file, click on the “Histogram” style, select the same parameter as previously, but click on the “Overlay” button to create the overlay (not the “Read” button). The histogram will be plotted on top of the previous one.

You can overlay up to 12 histogram parameters on the same graph. You can also change the color of the different histograms using the **Format Overlay** dialogue window (click on the graph and select “Format” in the popup menu. The “Histogram Control” box is for making changes to the original, or first histogram. The “Overlays” box is for making changes to the histograms overlaid on top of the original histogram.)
V. How to Create a Dual-parameter Histogram

If you decide to plot first a dual-parameter histogram, you need to choose which style of plot you want to draw from the three different styles displayed in the WinMDI Display dialog window: a dotplot, a density plot, or a contour plot.

1. How to create a dotplot

Select the “Dotplot” option in the WinMDI Display window and click the OK button. In the Open Dotplot window navigate in the folders and select the listmode data file you want to analyze. Press the OK button. The following window appears on the screen:

![Dotplot window](image)

Different options are displayed in order to create the dotplot.

- The name of the listmode data file is automatically displayed at the top of the window.

- Just below the filename, the user can select which parameter to display on the x axis and which one on the y axis. When selected, these two parameters appear in the “Parameter” box. To the right of this box, the “Amplifier/Scale” box display different possible scales for the axes. Select the first parameter (ex: FS on the previous figure) and then select the corresponding scale. Select “Linear” if this parameter has been recorded in linear mode. If this parameter has been recorded in logarithmic scale, then select the number of decades corresponding to the flow cytometer protocol setup (3 or 4 decades). Repeat all these steps for the second parameter.
• In the “Plot Number of Events” area, different options are available in order to display 2000 events only, or half, three quarters or all the events recorded. You can also set a specific number of events (type the value).

• In the “Draw Option” area are 6 check boxes. The first three are related to kinetics analyses where the intensity of one or several parameters is monitored with the time.

  The “Show XY Labels” check box needs to be checked in order to label the axes.

  The “Color 2D Regions” check box needs to be checked to color the events gated on a histogram. Gating and coloring events can be used simultaneously in order to localize on one or several histograms the events gated in another histogram. For more detail see VII. Regions and Gates.

• The “Log Grid 3D” check box is dedicated to histograms displaying three parameters at the same time. If this box is checked, a grid is applied on the different axes to underline the logarithmic scale. Of course this grid concerns only parameters acquired in the logarithmic scale.

Six buttons are also available on the “Format Dotplot” window.

Click the “OK” button to close the window when all the desired options have been selected.

The “Cancel” button closes the “Format Dotplot” window without taking into account the selected options.

The “Gates” button opens the Gate List dialog box in order to handle regions or gates (see VII. Regions and Gates).

The “New File” button allows you to change the listmode data file to work with.

The “3D Plot” is used to convert the current dual-parameter histogram into a 3-dimensional histogram. When this button is clicked the Select xyz dialog window appears. You can choose the three parameters to display. To select a parameter either double-click on it or select it and press the “>>” button. When a parameter is selected it is
listed in the right **X, Y, and Z Parameters** box. To remove or change one or all the parameters click the “Reset” button. When the three parameters are selected press the “OK button.”

The “Abort” button aborts the 3D transformation.

The “Help” button opens the WinMDI 2.8 help.

### 2. How to create a Density plot or a Contour Plot

These graphs are very useful to identify the borders between several close clusters. In the **WinMDI Display** dialog windows select the “Density Plot” or “Contour Plot” option and click the OK button.

In the new **Open Dotplot** dialog window, navigate in the folders and select the listmode data file you want to analyze. Press the OK button.

Whatever option is selected, the **Format 2D Display** dialog window appears on the screen. In fact it is not exactly the same window. Indeed, there is one difference: the “Density Plot” check box is checked only in the case of a density plot (see figure below). Later on, it is possible to shift from the density plot to the contour plot just by checking this box or not.

**Contour Plot:**

![Contour Plot]

**Density Plot:**

![Density Plot]
The **Format 2D Display** dialog window displays several pieces of information on the graph.

- The name of the listmode data file is automatically displayed in the top left corner.
- You can choose which parameters to display (X and Y parameters), the type of amplification (linear, or logarithmic), and the resolution.
- Check the “Density Plot” check box to draw a density plot histogram.
- Check “Label Axes” in order to label the two axes.
- The “Color” check box is used to display the different densities of events according to a color code set up automatically (check the “Calculate Colors” check box) or by the user (uncheck the “Calculate Colors” check box and choose a color through the “Display Colors” menu).

**Hint!**

I SUGGEST THAT YOU LET THE SOFTWARE HANDLE THE COLOR CALCULATION AND THE DIFFERENT OPTIONS DISPLAYED ON THE RIGHT OF THE WINDOW (CONTOUR). LATER ON, IT IS ALWAYS POSSIBLE TO CALL UP THIS WINDOW AND CHANGE SOME OPTIONS IN ORDER TO SMOOTH THE DENSITY OR THE CONTOUR LINES, TO SET UP A THRESHOLD, TO CHANGE THE THICKNESS OF THE LINES, TO SELECT ANOTHER ALGORITHM TO SET UP THE CONTOUR OR DENSITY PLOT, ETC.

**Hint!**

IT IS ALSO POSSIBLE TO CREATE A 3D HISTOGRAM BY CHECKING THE “SHOW 3D DISPLAY” CHECK BOX. THE DENSITY OF EVENTS WILL BE PLOTTED ON THE THIRD AXIS. IT IS THEN POSSIBLE TO COLOR ON THIS 3D HISTOGRAM THE EVENTS WHICH WOULD HAVE BEEN GATED ON THE 2D HISTOGRAM BY CHECKING THE “USE REGION COLORS” CHECK BOX. IT IS POSSIBLE TO CHOOSE THE COLOR USING THE “SET 3D FILL COLOR” MENU. IT IS ALSO POSSIBLE TO CHANGE THE ORIENTATION OF THE 3D DISPLAY BY CHANGING THE “ROTATION” ANGLE AND/OR THE “TILT” AND “DISTANCE” VALUES.
Five buttons are also available on the **Format 2D Display** dialog window.

- Click the “OK” button to close this window and display the graph when all the desired options have been selected.
- Click the “Cancel” button to close the dialog window without taking into account the last changes.
- The “Gates” button opens the “Gate List” dialog box and defines the regions or gates (see VII. Regions and Gates).
- Click the “New File” button to select another listmode data file.
- The “Help” button opens the WinMDI help file.

### 3. How to create a 3-dimensional display

It is possible to transform any histogram, dot plot, density plot, or contour plot into a 3D graph displaying three different parameters. A left click anywhere on the graph shows a new menu. A left click on the “Format” option opens the **Histogram Format**, **Dot Plot Format**, or **Format 2D Display** dialog window respectively for a histogram, a dot plot, or a density (or contour) plot. To display the 3D graph just check the “3D view” or “Show 3D Display” check box and press OK, or press the “3D Plot” button. These steps are reversible and it is thus possible to come back to a 2D graph.
It is possible to change the orientation of the 3D graph using the mouse. Just press the Ctrl key on your keyboard and at the same time click the mouse on the graph. The graph changes and displays then only an empty cube without any labeling (see below).

Just keep clicking the Ctrl key and the left mouse button and drag the mouse to change the orientation of the graph. When the desired orientation is reached, release the mouse button to display the graph.

4. How to change the parameter labels and font

WinMDI automatically labels the axes of the graphs. The default labels are those recorded in the listmode data file. To set new label(s), select in the tool bar Tool ➔ Parameter Labels (or press Alt+L) to open a dialog window. Type the new label(s), check the “Use these instead of file labels” check box, and press the OK button.

To change the font press F8 or select in the tool bar Window ➔ Set Defaults ➔ Font. Select the font, the style, the size, the effects, and the color. Click the OK button.

5. How to display a title or write annotations on a graph

You can write a title on each graph and add comments. Select in the tool bar Tools ➔ Annotate (or press Alt+A) to open the Annotation dialog window. Type the text or the title in the “Text” box. Choose the font, size, and style and press the OK button. Then move the mouse cursor and click with the left mouse button where you want to display the text.
You can move, modify or delete the annotation at any time.

- To **move** the text: just click on it and drag it.

- To **modify** the text: keeping the “shift” key pressed, double click on the annotation then type the new text and press “Enter”.

- To **delete an annotation or a title**: keeping the “shift” key pressed, double click on the annotation to select it and press the “Delete” key.

**VI. Zoom**

It is possible to magnify a particular area on any plot:

- Click with the right-button of the mouse on the plot of your choice and move the mouse in order to define the area to zoom in.
- Click with the left button of the mouse within the defined area. In the pop up menu click on **Zoom**.

To unzoom, click with the left button of the mouse anywhere in the plot and in the pop up menu select **Unzoom**.

Zooming and unzoming can be performed several times on the same plot.

**VII. How to Create and Display Several Graphs on the Screen**

To create a new graph once the first graph has been displayed, select in the tool bar the “Display” button and choose which type of graph you want to draw. Then repeat the previous steps to select the listmode data file to open and to define the settings of the graph.

When all the graphs are displayed, it is possible to resize them, to move them one by one, or to reorganize them automatically using the **Windows** button in the tool bar.

The **Windows ➔ Cascade** option superimposes the different graphs on top of each other and only the first one is visible. The **Windows ➔ Tile** option shares the screen between the different graphs which are thus all visible.
Several other options also allow the user to Minimize All, Restore All, and Close All graphs.

**Hint!**

To create a new graph when all the previous graphs are closed, click **File ➔ Open File**, choose the type of graph to display, and then navigate to the file to open.

### VIII. Regions and Gates

Now that you’ve learned how to open a listmode data file and display the main graphs, you need to learn how to create regions and gates. A region can be defined as set of points carefully selected by the user that determine an area on a graph.

One or several regions can be defined on the same graph (see Figure below).

The regions have to be distinguished from the gates. Gates are Boolean expressions containing one or several regions. So a gate can be equal to a region, but this is not always the case.
The regions are used to compute statistics for the subset of events selected by the user in a peculiar histogram. Moreover, this cluster can then be gated and its events colored on the other graphs.

WinMDI offers 4 different region styles. The “Histogram” region can be drawn only on a one-parameter histogram plot. The three other styles (“Polygon,” “SortRect,” and “Ellipse”) can be applied to any two-parameter graph.

No region can be directly drawn on 3D graphs.

1. Create a region on a 1-parameter histogram

To create a “Histogram” region click the left mouse button on the histogram graph where you want to draw the region. A popup menu will appear. Select “Regions” to open the 2D Regions Tool dialog window. Sixteen regions from R1 to R16 (R means region) are then listed with different colors. The events contained in a region will be colored. To change the color, click on the color and select another one. Select the “Histogram” region style (it should already be selected). Click the “Create” button. The Set Region Tool dialog window appears. On the histogram click with the left mouse button where you want to set up the lower (left) limit of your region. Then click with the right mouse button where you want to set up the upper (right) limit of the region. You have just created a marker (labeled from M1 to M8).

The lower and upper limits are displayed on the Set Region Tool dialog window. To transform a marker into a region (labeled R + a number) just press the “Create Region from Current Marker” button. To erase the marker just double-click with the right mouse button on it.
You can create other regions on the same histogram by creating a second marker. Just change the marker index and create a new marker on the histogram. Create a second region from this second marker. You can create up to 8 different markers or regions on the same histogram.

**Hint!**

You can also generate markers without generating a region to get statistics, but in that case the events cannot be gated on the other graphs. To create a marker just click the left mouse button on the histogram and select “Markers” in the popup menu. Then place the lower and upper limits of the marker as previously described.

2. **Create a region on a 2-parameter histogram**

On a 2-parameter histogram you can draw three different region styles. Click the left mouse button on the graph where you want to draw the region. A popup menu appears. Select “Regions” to open the 2D Regions Tool dialog window. Select the region style: Polygon, SortRect, or Ellipse (see figure below).
**Polygon Style**

The polygon style allows you to draw a polygonal region. Click on the graph where you want to start your region. You just defined the first point in the region. If you release the mouse button and move the mouse to a different position you will see a segment connecting the first point to your mouse pointer. Click to set up the second point in the region. Continue to move the mouse and click when you want to define a new point in the region. To close the region, you need to click on the first point.

**SortRect and Ellipse Styles**

The SortRect style allows you to draw a rectangular (or square) region. Click on the graph where you want to set the upper left corner of the region. Then keep the left mouse button pressed and move the mouse to draw the region. The region appears as a dashed line. When the region is correctly drawn, release the mouse button.

The ellipse style allows you to draw an elliptical (or circular) region. To draw such a region just processed as for the rectangular region.

### 3. How to create a quadrant

A quadrant can be used only in bivariate displays. Quadrant divides a graph into 4 regions: upper left (labeled UL), upper right (UR), lower left (LL) and lower right (LR).

To create a quadrant, click on a graph and select “Quadrant” in the popup menu. The 4 regions are displayed. To adjust the size and the localization of the regions you
need to activate the quadrant and then click where you want to display its center. To select the quadrant, you can double-click the center of the quadrant or press Alt+Q or click the “Tools” button in the main tool bar and select “Quadrant Tool.”

The quadrant position is used by WinMDI to calculate statistics within each of the four regions. The statistics can be displayed in the “Stats” window.

The percentage of events gated in each region is also displayed in each corner of the graph.

4. How to delete, move, or adjust a region

To delete a region

To delete a region, click on any graph with the left mouse button. In the popup menu select “Regions” to open the 2D Regions Tool dialog window. Select the region to delete (check its check box) and press the “Delete” option button. Close the dialog window. You can delete only one region at a time.

Hint!

Sometimes the deleted region is still displayed on the graph. To correct this artifact click on the tool bar WINDOW → REFRESH ALL (or press Alt+End).

To change the localization of a region or resize a region

For a 1-parameter histogram it is easier to delete the region and to draw a new one in the right localization.

For any 2-parameter graph (dot plot, density plot, or contour plot) the way regions are resized or moved is common to all region styles. To move a region, double-click on the region to select it and drag it to its new location. You can also move the label without moving the region. Just double click in the region to activate it, click on the label and drag it where you want. When done, release the mouse button.

To resize a region, double click on the region to display the size handles. Click on the handles and drag them to adjust the size of the region.
5. Create gates

“Gates” are Boolean expressions containing one or several regions. They are defined using the different logical operators AND, OR, and NOT to combine the different regions. But gates are not manually drawn like regions.

To define a gate on a graph, click on the graph and in the popup menu select “Gates” to open the Logical Gate Tool dialog window (see figure below).

The Logical Gate Tool dialog box consists of two lists. On the left part is the list of all the existing regions (R1, R2, etc.). On the right is the list of the logical operators.

To create a gate on the graph, you need to assign each necessary region with its correct logical operator.

When you select only one region, for instance R1, and the logical operator AND, this means that all the events of the region R1 will be gated on the graph and displayed. But if you also select the Region R2, and select also the AND operator for this region, then only the events which are in both R1 and R2 will be gated and displayed.

If we take the same example with the operator OR, then the events which are in R1 only, or in R2 only, or in both R1 and R2 will be gated and displayed.

The operator NOT must be used to gate the events of a region that you do not want to display. This is particularly useful when you want to get the statistical results of a cluster of events mixed with another cluster on the same graph (let’s say forward scatter vs side scatter). You can create a region around the “not desirable events” on another graph where your clusters are well separated (for instance fluorescence collected on
PMI vs Side Scatter) and thus gate them out of the forward scatter vs right scatter graph.

All regions not necessary to define your gate need to have the OFF logical operator selected.

**IX. Convert a FCS file to a text file**

1. **Convert a data file**

With WinMDI you can convert a FCS file into a text format. The data can thus be read by another software for further analysis beyond that of the regular flow cytometry software.

To convert an entire FCS data file, click on **File → Save As**, then:

- Select **Tabbed Text** from the file type list box,
- Under **File Name** type in the new file name,
- Click on **Save**.

**Hint!**

Under Preferences you can choose if the text must correspond to the channel value (if you work in linear scale) or to the arithmetic value (for log parameters).

2. **Only convert the data from a gated region**

Draw the region(s) you need to perform your gating and display only the cells of interest. The shape of the region(s) does not matter for converting the data. Click on **File → Save As**, then:

- Select **Tabbed Text** from the file type list box,
- Under **File Name** type in the new file name,
- Click on **Save**.
X. Display Statistics

You can display the statistics for any and all regions in WinMDI in the Stats window. To create the Stats window, click on a graph and select the “Stats” option. This window already contains certain information (file name, date, etc.) and some statistics. In the tool bar of this window click the “Format” button in order to open the Edit Statistics dialog window. This new window lists the different information that can be displayed in the Stats window. To select a field just check the corresponding check box, to unselect one just uncheck the check box.

The different statistics you can display for each region are:

- File name
- Sample ID/Title
- Date
- Cytometer
- % Total events
- % Gated events
- Markers
- Events
- Mean/CV
- Geometric log means
- Median
- Peak channel value
- Parameters
- Range
- Use Tabbed Format

When the statistics are displayed you can use the tool bar buttons of the Stats window to perform different operations:

- You can update the statistics (press the “Update” button) each time you move, remove, or create a region on a graph;
- You can save the statistics in a text format (.txt) in a new file, in order to read them with different software (press the “SaveAs” button). This new file can be named as you want; just type a new name instead of the default “statfile.txt” name.
- You can also print the statistics (press the “Print” button).
- The “Owner” button is used to show you on which graph you clicked to create the “Stats” window.
Hint!

You can add or remove some text directly in the “Stats” window. Just click into the window where you want make the modification and delete or type the text.

You can also directly display the statistics for each 1-parameter histogram by selecting Display → Screen Stats.

XI. Work with a Batch File

You can generate a working list of data files in order to aid in the automation of their analysis. You create each graph only once and then you can navigate between the listmode data files you want to analyze and/or compare. You save time.

To create a list click on File → List ... or press Ctrl +I, then select the listmode data files. To select the different files you need to press the Ctrl key + click the left mouse button on the different files. When the list is defined, you can work up and down the list using the File → Next File and Prev File.

Click “OK” to retain the list; “Cancel” to delete it; and “Reset” to create a new list. The “Close” button closes the list.

Hint!

You need to update each graph with the file you want to work. You can use the Next or Previous File buttons. But you can also click on a graph, then select the file in the “File List Dialog” dialog window and press the OK button of the dialog window. Repeat these steps for each graph.

Hint!

If the files are in the same directory and labeled with incremented names (i.e., 0628PI01, 0628PI02, 0628PI03 or 06P1A, 06P1B; etc.) you can directly load the next file by selecting File → Next File, or work on the previous file by clicking on the Previous File option. Note that the file names in the directory must constitute a continuous suite of numbers or letters.
**XII. Overview**

<table>
<thead>
<tr>
<th>What we like…</th>
</tr>
</thead>
<tbody>
<tr>
<td>• <strong>WinMDI</strong> version 2.8 is able to read FCS 1.0 and FCS 2.0 data files, that is to say the major part of listmode data files from current flow cytometers.</td>
</tr>
<tr>
<td>• You can create and display multiple graphs simultaneously on the screen. You can choose among 5 standard types: histogram, dot plot, density plot, contour plot, or isometric. The 3D graphs are very nice and you can rotate or tilt them.</td>
</tr>
<tr>
<td>• You can copy and paste the graphs into other software (useful for publication).</td>
</tr>
<tr>
<td>• You can overlay several histograms.</td>
</tr>
<tr>
<td>• You can gate events in color regions using the mouse, use quadrants, and get statistics. A complex gating can be done using logical operators (AND, OR, and NOT).</td>
</tr>
<tr>
<td>• Dual-parameter histograms can display a grid. Very useful to underline the intensity shifts in any parameters.</td>
</tr>
<tr>
<td>• Time can be used as a region/gating parameter if it is a recorded parameter.</td>
</tr>
<tr>
<td>• The medians and means for log-acquired data are converted to a linear intensity scale.</td>
</tr>
<tr>
<td>• Once a graph has been created, it is possible to use the drag &amp; drop capability to read a new data file. Just select the new FCS data file within your file manager, drag the icon to WinMDI, and drop it in the selected graph.</td>
</tr>
<tr>
<td>• The most commonly used functions are directly available from a pop-up menu.</td>
</tr>
</tbody>
</table>
What we dislike…

- No tutorial is provided with the software.
- The quadrant analysis is supported but the results cannot be shown on the dot plot itself.
- Kinetics are difficult to perform (the median Y line cannot be drawn vs. time; the event number cannot be used as a dot-plot X parameter if time is not a recorded parameter; the medians cannot be obtained for a user-specified number of slices of each listmode file).
- The cell cycle analysis on DNA fluorescence histograms is not supported (no model or algorithm available).
- The histogram vertical scaling is adjustable only in factors of two.
- You may need to perform “Refresh” of the different graphs in order to remove display bugs on the screen.
Quick Start in 10 steps

1. To start WinMDI 2.8
   1. Open WinMDI by clicking on the WinMDI2.8 icon on the desktop
   2. A WinMDI display box will appear with histogram highlighted, just select OK
   3. Select data file from appropriate directory > OK
   4. Select Show all parameters > READ
   5. Left click on the window
   6. Select format
   7. Change Y scale to rescale histogram

2. To display a 2-parameter histogram
   1. Click on Display at the top > Select Dot Plot, or Density plot, or Contour plot
   2. Select file or OK
   3. Select X-axis
   4. Select Y-axis
   5. Select the number of events you want to display. In “plot number of events” section select from the choices how many events you want to show. (It defaults to 2,000 events.) You may also type in a specific number of events by choosing SET.
   6. OK

3. To create a 3D plot
   1. Display dot plot, plotting 2 of the parameters
   2. Left click on histogram
   3. Select format
   4. Select 3D plot
   5. Click on first parameter > Select parameter
   6. Click on second parameter > Select parameter
   7. Click on third parameter > Select parameter
   8. OK
4. To rotate a 3D graph
1. Left click on histogram
2. Select rotate
3. Use the Ctrl key and the left button of the mouse over the display to change the orientation.
4. Close

5. To display a new single-parameter histogram
1. Select Display > Histogram
2. Select file > OK
3. Select the parameter you wish to display
4. Click on READ

6. To create a region…
   …on a 1-parameter histogram
1. Create the histogram display you want
2. Click on the histogram window
3. Select Markers
4. Create the marker/markers you want to use as regions
5. Close the markers dialog box
6. Right click on the histogram again
7. Select Regions: the first to create will be R1
8. Click on the Create button to get the Markers -> Region tool
   - use the top half to select the marker you want to become a region
   - then click the create Region from current marker button to copy the marker into a new region. Do this for each histogram marker you want to be a region
9. Close the tool dialog box by clicking OK.

   …on a 2-parameter histogram
1. Left click in the 2-parameter histogram in which you wish to create a region
2. Select Regions
3. Select the region style
   a. polygon
   b. sortrect
   c. ellipse
4. Click on Create
5. Draw region on the graph
6. Click OK to close the dialog window

7. To create gates
1. Left click on the histogram to which you wish to apply this region
2. Select Gates
3. Select the region you want to use
4. Set a region logic operator (AND, OR, and NOT) for each region to combine

<table>
<thead>
<tr>
<th>Logic operator</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Off</td>
<td>none</td>
</tr>
<tr>
<td>And</td>
<td>event must always be within this region</td>
</tr>
<tr>
<td>Or</td>
<td>event can be within this region</td>
</tr>
<tr>
<td>Not</td>
<td>event cannot be within this region</td>
</tr>
</tbody>
</table>

8. To display statistics…
   …on a 1-parameter histogram:
1. Click on Display
2. Check screen stats

   …in the STATS window:
1. Left click on histogram
2. Select stats
9. **To create histogram overlay**

1. Open first histogram:
   - File > Open
   - Read

2. Open second histogram and click on **Overlay** instead of **Read**

   **NOTE:** the read single box must be checked to give the overlay option

3. Continue to add histograms you want on the overlay.

   **NOTE:** Open and overlay all histograms before doing any formatting at all.

4. Left click on the overlay histogram

5. Select format (do whatever formatting you want):
   a. Rescale
   b. Take off solid fill, etc.

   **NOTE:** The **Histogram Control** box is for making changes to the original or first histogram. The **Overlays** box is for making changes to the histograms overlayed on top of the original histogram.

10. **To create 3D view of histograms**

1. Make overlay

2. Left click on histogram

3. Select **Format**

4. Select **3D view**

5. To rotate:
   a.) click on histogram
   b.) select **Rotate**
   c.) use **ctrl** key and left mouse button over the display to change the orientation

6. Close